<!doctype html>
<html data-n-head-ssr>
  <head >
    <title>Saudi Crown Prince Returns to World Stage, Upgrade in Israel Relations Expected</title><meta data-n-head="ssr" charset="utf-8"><meta data-n-head="ssr" name="viewport" content="width=device-width, initial-scale=1"><meta data-n-head="ssr" data-hid="description" name="description" content="Saudi Arabia&amp;rsquo;s Crown Prince Mohammed bin Salman (MBS) toured the Middle East this week&amp;mdash;stopping in Egypt, Jordan and Turkey&amp;mdash;marking his return to the international stage after becoming a pariah following the murder of journalist and Saudi government critic Jamal Khashoggi. 
What does the return of MBS mean, and will it have repercussions for Israel?
&amp;ldquo;A victory tour is a good way of putting it,&amp;rdquo; Joshua Teitelbaum, a professor in the Department of Middle Eastern Studies at Bar-Ilan University in Ramat Gan, told JNS.
Teitelbaum speculated that the Saudis and Israelis might open &amp;ldquo;interest sections&amp;rdquo; in embassies of third countries. An &amp;ldquo;interest section&amp;rdquo; is a way for a country to offer consular services in a state with which it doesn&amp;rsquo;t have diplomatic relations. America, for example, uses the Swiss embassy in Iran."><meta data-n-head="ssr" data-hid="robots-follow" name="robots" content="follow"><meta data-n-head="ssr" data-hid="robots-index" name="robots" content="index"><meta data-n-head="ssr" data-hid="og:url" property="og:url" content="https://www.newsrael.com/posts/u3vdvg8avcs"><meta data-n-head="ssr" data-hid="og:title" property="og:title" content="Saudi Crown Prince Returns to World Stage, Upgrade in Israel Relations Expected"><meta data-n-head="ssr" data-hid="og:description" property="og:description" content="Saudi Arabia&amp;rsquo;s Crown Prince Mohammed bin Salman (MBS) toured the Middle East this week&amp;mdash;stopping in Egypt, Jordan and Turkey&amp;mdash;marking his return to the international stage after becoming a pariah following the murder of journalist and Saudi government critic Jamal Khashoggi. 
What does the return of MBS mean, and will it have repercussions for Israel?
&amp;ldquo;A victory tour is a good way of putting it,&amp;rdquo; Joshua Teitelbaum, a professor in the Department of Middle Eastern Studies at Bar-Ilan University in Ramat Gan, told JNS.
Teitelbaum speculated that the Saudis and Israelis might open &amp;ldquo;interest sections&amp;rdquo; in embassies of third countries. An &amp;ldquo;interest section&amp;rdquo; is a way for a country to offer consular services in a state with which it doesn&amp;rsquo;t have diplomatic relations. America, for example, uses the Swiss embassy in Iran."><meta data-n-head="ssr" data-hid="og:image" property="og:image" content="https://d1qvt830j8jy97.cloudfront.net/images/2022-06/3744c4d846cfdc82d3a02d38.jpg"><meta data-n-head="ssr" data-hid="og:type" property="og:type" content="article"><link data-n-head="ssr" rel="icon" type="image/x-icon" href="/favicon.png"><link data-n-head="ssr" rel="alternate" type="application/rss+xml" title="RSS 2.0" href="/rss/feed.xml"><link data-n-head="ssr" rel="canonical" href="https://www.newsrael.com/posts/u3vdvg8avcs"><script data-n-head="ssr" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" data-ad-client="ca-pub-6028060720840931"></script><script data-n-head="ssr" data-hid="adsbygoogle-script" defer crossorigin="anonymous" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-6028060720840931"></script><script data-n-head="ssr" data-hid="adsbygoogle">if (!window.__abg_called){ (window.adsbygoogle = window.adsbygoogle || []); adsbygoogle.pauseAdRequests=0;
          adsbygoogle.push({
      google_ad_client: "ca-pub-6028060720840931",
      overlays: {bottom: false},
      enable_page_level_ads: true
    }); window.__abg_called = true;}</script><link rel="preload" href="/_nuxt/34a9f7c.js" as="script"><link rel="preload" href="/_nuxt/bd8ef49.js" as="script"><link rel="preload" href="/_nuxt/84b0c7d.js" as="script"><link rel="preload" href="/_nuxt/b25b38f.js" as="script"><link rel="preload" href="/_nuxt/a01d2ba.js" as="script"><link rel="preload" href="/_nuxt/415d694.js" as="script"><style data-vue-ssr-id="27aacee6:0 80711072:0 7b7a8ae4:0 2d79f4b2:0 066afca0:0">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</style>
  </head>
  <body >
    <div data-server-rendered="true" id="__nuxt"><!----><div id="__layout"><div class="full_height"><header class="b_header"><div class="container"><div class="header_wrapper flex"><div class="header_main_control"><div class="logo_wrapper"><a href="/" class="logo_link nuxt-link-active"><img></a></div> <div class="date_wrapper"><span></span>
                    25 Jun, 2022
                    <span></span>
                    02:26
                </div></div> <div class="buttons_control"><div class="btn_wrapper"><a href="/" title="Main" class="btn_icon btn_main nuxt-link-active"></a></div> <div class="btn_wrapper"><a href="/archive" title="Archive" class="btn_icon btn_archive"></a></div> <div class="btn_wrapper"><button title="Settings" class="btn_icon btn_settings jsOpenDropDown"></button> <div class="dropdown_list_wrapper"><div class="dropdown_list"><div class="list_row"><a href="/cdn-cgi/l/email-protection#573e39313817393220242536323b7934383a" class="list_link"><span class="images_wrapper"><span class="static_img"><img></span> <span class="active_img"><img></span></span> <span class="title">Support</span></a></div> <div class="list_row"><a href="/terms-of-use" class="list_link"><span class="images_wrapper"><span class="static_img"><img></span> <span class="active_img"><img></span></span> <span class="title">Terms of Use</span></a></div> <div class="list_row"><a href="/privacy-policy" class="list_link"><span class="images_wrapper"><span class="static_img"><img></span> <span class="active_img"><img></span></span> <span class="title">Privacy Policy</span></a></div> <!----></div></div></div></div></div></div></header> <main class="main_wrapper full_height"><div class="container full_height"><div class="b_content flex full_height"><div data-fetch-key="0" class="b_sidebar_wrapper"><div class="hashtags_wrapper"><div class="hashtag_label"><a href="/hashtags">
                Hashtags
            </a></div> <div id="customHashtagsScrollbar" class="hashtags_list"><ul><li><a href="/hashtags/biden-administration">
                        # Biden Administration
                    </a> <div class="posts_counter"><span>1047</span> Posts
                    </div></li><li><a href="/hashtags/war-in-ukraine">
                        # WAR IN UKRAINE
                    </a> <div class="posts_counter"><span>906</span> Posts
                    </div></li><li><a href="/hashtags/hezbollah">
                        # Hezbollah
                    </a> <div class="posts_counter"><span>813</span> Posts
                    </div></li><li><a href="/hashtags/the-iranian-threat">
                        # The Iranian Threat
                    </a> <div class="posts_counter"><span>714</span> Posts
                    </div></li><li><a href="/hashtags/israelinature">
                        # Israeli_Nature
                    </a> <div class="posts_counter"><span>464</span> Posts
                    </div></li><li><a href="/hashtags/operation-guardian-of-the-walls">
                        # Operation Guardian of the Walls
                    </a> <div class="posts_counter"><span>379</span> Posts
                    </div></li><li><a href="/hashtags/ukraine-crisis">
                        # Ukraine Crisis
                    </a> <div class="posts_counter"><span>262</span> Posts
                    </div></li><li><a href="/hashtags/idf">
                        # IDF
                    </a> <div class="posts_counter"><span>218</span> Posts
                    </div></li><li><a href="/hashtags/the-bible">
                        # The Bible
                    </a> <div class="posts_counter"><span>160</span> Posts
                    </div></li><li><a href="/hashtags/israeli-heroes">
                        # Israeli Heroes
                    </a> <div class="posts_counter"><span>147</span> Posts
                    </div></li><li><a href="/hashtags/israeli-medical-tech">
                        # Israeli Medical Tech
                    </a> <div class="posts_counter"><span>122</span> Posts
                    </div></li><li><a href="/hashtags/muslim-persecution-of-jews">
                        # Muslim Persecution of Jews
                    </a> <div class="posts_counter"><span>31</span> Posts
                    </div></li></ul></div></div></div> <div class="b_main_content"><div class="main_content_wrapper"><div class="b_single_post"><div class="posts_list"><ins data-ad-client="ca-pub-6028060720840931" data-ad-slot="2397464790" data-ad-format="auto" data-ad-region="page-0.993324233730716" class="adsbygoogle" style="display:block;margin-bottom:10px;"></ins> <div><div class="post_card box_shadow"><div class="category_wrapper"><div class="category dib blue" style="background-color:#DEEBFF;color:#0038B8;">
                Israel - Saudi Arabia
            </div></div> <div class="post_container"><div class="post_header"><div class="writer_wrapper flex"><div class="writer_image_wrapper"><div class="image_wrapper"><span class="writer_image"><img src="https://d1qvt830j8jy97.cloudfront.net/images/2021-04/55e98db599182f2805fca223_240.png"></span></div></div> <div class="post_title">
                        Saudi Crown Prince Returns to World Stage, Upgrade in Israel Relations Expected
                    </div></div> <div class="post_information"><span class="writer_name">UNITED  WITH ISRAEL</span> <span class="post_time">08:30</span> <span class="post_date">18 hours ago</span></div></div> <div class="post_content"><div class="content"><div><p><strong>Saudi Arabia&rsquo;s Crown Prince Mohammed bin Salman (MBS) toured the Middle East this week&mdash;stopping in Egypt, Jordan and Turkey&mdash;marking his return to the international stage after becoming a pariah following the murder of journalist and Saudi government critic Jamal Khashoggi. </strong></p>
<p>What does the return of MBS mean, and will it have repercussions for Israel?</p>
<p>&ldquo;A victory tour is a good way of putting it,&rdquo; Joshua Teitelbaum, a professor in the Department of Middle Eastern Studies at Bar-Ilan University in Ramat Gan, told JNS.</p>
<p><span style="color: #000000; font-family: 'open sans', 'helvetica neue', Helvetica, Arial, sans-serif; font-size: 16px; font-style: normal; font-variant-ligatures: normal; font-variant-caps: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color: #ffffff; text-decoration-thickness: initial; text-decoration-style: initial; text-decoration-color: initial; display: inline !important; float: none;">Teitelbaum speculated that the Saudis and Israelis might open &ldquo;interest sections&rdquo; in embassies of third countries. An &ldquo;interest section&rdquo; is a way for a country to offer consular services in a state with which it doesn&rsquo;t have diplomatic relations. America, for example, uses the Swiss embassy in Iran.</span></p></div></div> <!----> <div class="post_image_wrapper"><picture></picture></div></div> <div class="post_hashtag_list"><a href="/hashtags/israeli-saudi-arabia">
                    # Israel - Saudi Arabia
                </a><a href="/hashtags/muhammad-bin-salman-mbs">
                    # Muhammad bin Salman (MBS)
                </a></div> <div class="post_footer flex"><div class="social_wrapper"><div class="social_list"><a href="https://www.facebook.com/sharer/sharer.php?u=https://newsil.page.link/Dx8z2zTeWfkGqgxB6" target="_blank" class="social_link social_facebook"></a> <a href="https://api.whatsapp.com/send?text=https://newsil.page.link/Dx8z2zTeWfkGqgxB6" target="_blank" class="social_link social_whatsapp"></a> <a href="https://twitter.com/intent/tweet?url=https://newsil.page.link/Dx8z2zTeWfkGqgxB6" target="_blank" class="social_link social_twitter"></a> <a href="/cdn-cgi/l/email-protection#48773b3d2a222d2b3c751b293d2c21680b3a273f2668183a21262b2d681a2d3c3d3a263b683c27681f273a242c681b3c292f2d64681d382f3a292c2d68212668013b3a292d24681a2d24293c2127263b680d30382d2b3c2d2c6e292538732a272c3175203c3c383b726767262d3f3b21246638292f2d6624212623670c3070327a321c2d1f2e230f392f300a7e" target="_blank" class="social_link social_mail"></a></div> <a href="https://madmimi.com/signups/94287d6aa2d345dfb8677b6baecd0201/join" target="_blank" class="newsletter_button dib"><div><span>Subscribe to our Newsletter</span></div></a></div> <!----></div></div></div> <div class="comments_wrapper"><!----> <div class="comments_form_wrapper flex no_comments"><div class="user_icon_wrapper"><div class="image_wrapper"><span class="writer_image bg_image"></span></div></div> <div class="form_wrapper"><div class="textarea_wrapper"><div class="char_wrapper"><span>0</span> <span>/200</span></div> <textarea placeholder="Write a comment..." rows="6" maxlength="200" class="form_control"></textarea> <button class="btn btn_template">
                    Comment
                </button></div></div></div></div></div> <ins data-ad-client="ca-pub-6028060720840931" data-ad-slot="2397464790" data-ad-format="auto" data-ad-region="page-0.45413433078693255" class="adsbygoogle" style="display:block;margin-top:10px;"></ins></div></div> <div class="development"><span class="title">Website By </span> <a href="https://www.prpl.io/?ref=newsrael_footer" target="_blank" class="link_logo"><img></a></div></div></div> <div class="b_sidebar_wrapper"><div class="flag"></div></div></div></div></main> <div><div class="b_footer_menu"><div class="footer_menu flex"><div class="menu_item"><a href="/" class="menu_btn btn_home nuxt-link-active"><div class="icon_wrapper"></div></a></div> <div class="menu_item"><a href="#" class="menu_btn btn_reporting"><div class="icon_wrapper"></div></a></div> <div class="menu_item"><a href="/settings" class="menu_btn btn_profile not_logged"><div class="icon_wrapper bg_image"><!----></div></a></div></div></div> <!----> <!----></div></div></div></div><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>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</script><script src="/_nuxt/34a9f7c.js" defer></script><script src="/_nuxt/a01d2ba.js" defer></script><script src="/_nuxt/415d694.js" defer></script><script src="/_nuxt/bd8ef49.js" defer></script><script src="/_nuxt/84b0c7d.js" defer></script><script src="/_nuxt/b25b38f.js" defer></script>
  </body>
</html>
